package net.i2p.data

Common data structures used by the I2P protocols: Destination, LeaseSet, PublicKey, Signature, Certificate and their friends. All implement the Data interface for serialization to and from the network wire format.

Router-specific structures (RouterInfo, RouterIdentity, RouterAddress) are in net.i2p.data.router; the I2CP wire messages are in net.i2p.data.i2cp.

See also: RFC 1951 (DEFLATE) • RFC 1952 (GZIP) • RFC 4648 (Base32, Base64 and Hex).